3

I am using Emacs 24.4 with Ubuntu 14.04. I just discovered that the C-M keyboard sequences are not working in Emacs. For example in elisp-mode the key C-M-left is bound to backward-sexp, but when I press Ctrl+Alt+"Arrow Left" nothing happens.

If I try describe-key and type some key combination with Ctrl+Alt nothing happens, but pressing Ctrl+Left, or Alt+Left works fine. Also pressing Ctrl+Alt+L locks the computer, which indicates that the desktop intercepts the Ctrl+Alt keystrokes before Emacs gets them..

Update

I can confirm that the key C-M-r is in fact working, so I think this is an indication that there is a conflict with the Ubuntu desktop keyboard shortcuts somewhere.

4

Checking the Ubuntu system-settings :System-settings->keyboard->shortcuts->navigation, shows that Ctrl+Alt+Left was bound to "Switch to workspace left" and Ctrl+Alt+Right was bound to "Switch to workspace right". Disabling these two shortcuts solved the problem.

  • OS X 10.8, VirtualBox, Ubuntu 15] First, how do you find the command to which a key is bound? How did you find Ctrl+Alt+Left? This would work only for specific keys. I want Emacs to capture all Ctrl+Alt key combinations (except perhaps for a few special ones to interact in the normal way with Ubuntu). Ctrl+Alt+... keys are seen by Emacs as if neither Ctrl nor Alt were held down. Ctrl key combinations work, and Alt (option on my Apple keyboard) key combinations work by themselves, just not together. – Mitchell Model Mar 24 '16 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.