3

Fairly new to emacs, seemed super awesome for writing a lot of different styles. Got it working just find on my desktop using the new bash terminal - 14.04 - on my desktop.

Did the exact same setup of emacs on 14.04 on my laptop ( just installing straight from sudo apt-get install emacs ), when I launch the package manager, if I hit any keys, this happens: Emacs crash immediately after launching list-packages and hitting an arrow key

Then, if I just use fg to try to get back into emacs, my terminal basically stops working and this happens when I press keys:

Emacs crash after fg

I googled around for a long time, and saw no similar crashes, and tried to wipe Emacs/reinstall, and the same thing was happening. I even updated linux to see if that would be a cause, and the exact same bug is happening.

I am not sure where to start for the reason behind this or how to approach debugging this. This does also happen with emacs -q.

Any help super appreciated, would love to use the program, I have been using on my desktop for a week or two to write C and other things, and it seems like a pretty ideal program if I could get it to work on both my laptop and desktop.

This will also happen occasionally when I just enter emacs or emacs -q without loading up a file and when I hit any key, the same crash will occure and exhibit the same behavior. It will always do the exact same thing in list-packages

  • A crash always represents an Emacs bug. Please report it, providing as much info as you can: M-x report-emacs-bug. – Drew Dec 13 '16 at 20:52
  • How can I send a bug report using one computer for another? The bug report seems to cause this particular brand of crashing too. What do I need to include for this bug report to be useful? – Fiend394 Dec 15 '16 at 23:15
  • Just send mail to bug-gnu-emacs@gnu.org. – Drew Dec 16 '16 at 1:48
  • Emacs works fine until you run list-packages. After this if you type U or g or any key, the emacs process gets suspended and you get bash shell prompt. – Babu Srinivasan Mar 14 '17 at 7:29
  • Note: this was filed as Bug#25221. It's not a crash, it's a suspend, and is probably a bug in the WSL/windows bash platform (which is still in beta, afaik). – npostavs Aug 22 '17 at 12:54
0

I am also experiencing exactly the same problem with emacs on windows bash. However I have noticed that if I run emacs on graphical environment it DOES NOT get suspended when running package list. You can try that if you like running emacs with your plugins. Check here graphical-linux-apps on how to run graphical applications.

0

Had the same problem: I do believe it is not an Emacs bug, but a WSL bug for the version of WSL that is now called the legacy version. After updating to the new (October 2017) Creator's Update and installing the Ubuntu from the Windows store the bug is gone. Works both for Emacs 24 from the repos and Emacs 25.3 that I compiled from the source.

I both apt-cloned my setup and copied my whole home directory over, so it is unlikely that this would be affected by a change other than moving from the previous Windows 10 version and WSL to the new versions for both.

The reason why I went through the trouble of reinstalling Ubuntu from the Windows Store is that it was recommended here https://www.reddit.com/r/bashonubuntuonwindows/comments/764mn9/can_i_keep_my_original_ubuntu_wls_installation/donmywr/ by that subreddit's moderator who I also believe the be one of the WSL developers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.