0

using meta + x then package install I tried installing a theme. I am able to apply it and it looks great... problem is if i restart spacemacs the following happens:

Found 1 orphan package(s) to delete... --> deleting color-theme-sanityinc-tomorrow... [1/1]

anyone know how to fix this? I tried googling and changing my settings (specially this setting dotspacemacs-install-packages 'used-only)), but nothing seems to help.

2

Don't install packages with package install. See the FAQ here: https://github.com/syl20bnr/spacemacs/blob/master/doc/FAQ.org#why-are-packages-installed-with-package-install-automatically-deleted-by-spacemacs-when-it-boots

Instead, install packages with dotspacemacs-additional-packages, or create a layer, or set the variable dotspacemacs-install-packages to used-but-keep-unused which will prevent Spacemacs from removing the packages you installed manually.

As for themes, just install the themes-megapack layer to get a bunch of different themes. The page for it is here: https://github.com/syl20bnr/spacemacs/tree/master/layers/%2Bthemes/themes-megapack

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.