1

I am pretty new to emacs. does anyone how to turn off special character, such as 渘 ? I tried to search online but no luck.

  • emacs 28 enter image description here
8
  • 2
    It’s hard to tell what we’re looking at from such a minimal screenshot, but is that your modeline? If so, you have definitely customized it (or used someone else’s customizations), so the answer is to examine those customizations and understand what they do.
    – db48x
    Aug 16, 2022 at 23:27
  • I'd hazard a guess that the custom mode line is intending to display a particular icon, but that the font uses that codepoint for the "special character" shown in the screenshot rather than the icon that was intended. So changing fonts might also have the desired effect. (If changing fonts is an option -- if not, you'll have to change it in the mode line customisations.)
    – phils
    Aug 17, 2022 at 1:19
  • 1
    If you don't use that init.el file, do you see a problem? If not, you can bisect that file to zero in on what is causing it. IMO, it's always a bad idea to try somebody else's initialization wholesale. You are much better off starting with nothing and then adding in what you want one thing at a time.
    – NickD
    Aug 17, 2022 at 2:23
  • 1
    As @Phil say - (setq doom-modeline-icon nil) if your config is for emacs or (setq doom-modeline-modal-icon nil) if you use evil.
    – Ian
    Aug 17, 2022 at 7:53
  • 1
    thank you all! will try them out.
    – eric123
    Aug 17, 2022 at 22:30

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.