When I am using ido, it only shows the folders and not the files within the folders. I have the following code in the init.el file:

;;Setup ido                                                                 
(ido-mode 1)                                                                
(setq ido-find-file t)                                                      
(setq ido-everywhere t)                                                     
(setq ido-enable-flex-matching t)                                           
(setq ido-default-file-method 'selected-window)                             
(setq ido-default-buffer-method 'selected-window)                           
(setq ido-use-filename-at-point 'guess)

Can't understand why this is happening. Any tips are appreciated.

  • Where exactly is it showing the folders? What do you do to show them? If you are doing C-x C-f it may be truncating the list: are there three dots at the end? If so, there are too many completions for ido to show you in the echo area: you'll have to help it by giving it a bit more information, e.g. the first few letters of the file name you are looking for. Pressing TAB will show you a buffer with all the completions.
    – NickD
    Sep 2, 2022 at 1:49
  • @NickD thank you for your answer, I did use C-x d, and that why I didn't could see all the files.
    – Anton
    Sep 2, 2022 at 13:16
  • C-x d calls dired; it would be counter-productive for that command to offer non-directory completion options. (Well... actually, you can enter a non-directory and get a dired buffer showing the matching files... you probably wouldn't want that for a specific single file, though... I think it's primarily intended to be used with glob patterns.)
    – phils
    Sep 3, 2022 at 8:53


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.