0

Cursor does not show the bottom section such as _ or bottom part of character g. This is the case in emacs -q -nw file.py and also the case in my init.el file. I am not sure how can I fix this issue.

_g
_g

enter image description here

enter image description here

I am using emacs under iTerm, where it has smart-box setting it on. Smart-box should let cursor's color as: character's color to be the background color and character's color to be black.

enter image description here


Sometimes cursor's background and foreground color becomes the same, where I don't know how that happens

enter image description here

1
  1. Have you tried a different font? The cursor shape is likely not easy to change, but the font should be.

  2. You can also increase line spacing: See (elisp) Layout Parameters and (elisp) Special Properties.

  3. You can also try to change frame parameter cursor-type or user option cursor-type. (They allow the same values.) You can set the height of the cursor with them. But I don't know whether that will override what iTerm imposes.

7
  • From Customize Face => Cursor I tried to change its color and height but it does not apply :( – alper Mar 20 at 14:06
  • You have to change font in iTerm's setting not in Emacs – matteol Mar 20 at 15:06
  • Ah in iTerm I have font 11 , v|i 80 and n/n 80 will play and and see will make a difference – alper Mar 20 at 18:18
  • @Drew is there any default height value ? can we also make a change within init.el and play around to see which height value could be the best – alper Mar 20 at 18:20
  • Default in what way? Each font has a height. You can experiment by changing the font frame parameter (among other ways). – Drew Mar 20 at 23:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.